Yes!
Starting with Vimalin 2.5.481 and VMware Player 16.0 we do now support VMware Player.